Disassembling continues

Hmm, that transmission crossmember looks strange:

20180825_205210.jpg

Yup, not supposed to look like that seems someone hit something pretty hard, luckily no other damages:

20180826_124318.jpg

Bracked for ABS-unit needs straightening:

20180826_125133.jpg

New hinges:

20180826_150007.jpg

Note to self, don’t start engine while forgetting plastic bag over intake because you were smart and covered it no to get debris in:

20180826_150145.jpg

Need these parts new for the front:

20180826_164157.jpg

This corner needs som fixing:

20180826_200742.jpg

20180826_200747.jpg

Solving rough running + disassemble

The car has been running rough, runs good cold but when it gets warm one cylinder has been misfiring, I knew from reading codes it was cylinder 5 and I suspected the ignition coil, they usually break.

Ordered 2 used ignition coils to have a spare if I run into more broken ones.

Was going to drive the car for 350 km to the garage, so replaced the coil and off I went, didn’t get far until Check engine light came on. I had also bought new sparkplugs for service, so at a petrolstation outside Gävle I replaced the sparkplug, Check engine light gone and it runs perfect:

Next day I replaced the rest of the sparkplugs + airfilters and cabinfilter:

20180825_105005.jpg

Washed it:

20180825_115339.jpg

20180825_115347.jpg

And started taking it apart to fix the cosmetics:

20180825_130847.jpg

Fender comes off:

20180825_173628.jpg

Got all the broken plastic off from the underside, hotwater cleaned it:

20180826_140324.jpg

 

Project restart

Standstill for 2 years, but this summer things finally started going the right way.

First, ordered a complete used passengers seat from California to solve Airbag/Belt/SRS problems, it did after some calibration at Wikmans bil in Gävle.

I also had the car registered and it past inspection=legal to drive.

ABS/ESP

Since car always said ABS and ESP not working and I cleaned the wheel sensors and the steering angle sensor I started looking for something else, this can’t be good:

Need new bracket also:

Bought the whole Traction system hydraulic unit(A7/3), but then did some reading and when system is just woken it is 60 bar of pressure, when working 160 bar, so gave it a shot just swapping the control unit:

They are “identical” but different part number, mine comes off a E500:

Magically ESP warnings gone, ABS warnings gone, Adaptive steering is back in working order and Cruise control started working. Case closed.

Rough running

Engine is running kind of rough, especially when idling and can stutter from time to time, but never with a heavy foot on the pedal. Saw that I forgot to connect the airpump to the airbox, gave me the idea to look for other hoses that might be loose.

Off with the airbox, saw the conntector to the LMM was a little bit strange, and yes, LMM has been replaced, it has junkyard writings:

Then noticed this:

Since when is it ok to repair large wholes with tape? Also a lot of cracks and not fitting well, loose:

Ordered a new one:

In place:

LMM back:

Check engine light gone, still a little rough, pulled code and got misfire on Cyl 5, changed ignition coils between cyl 5 and 6 to see if error moved. But unfortunately no more errors and still running same, might need to drive more.